Pricing and Discounts

section divider

Licensing

section divider

Support & maintenance

  • How to I renew my license?

    Instruction and renewal license type varies depending on your license type. Please select the license type you have.

    • Individual License (Perpetual)
    • Individual Subscription License (Annual, monthly, 3-month, 6 month)
    • Team License (Perpetual)
    • Team License (Annual)
    • Faculty Site License (Campus-wide license)
    • Individual Academic License
  • How can I update software?
    1. Go to [Help] – [Software Update Information] in Astah.
    2. If Availability says “Y”, click [Download Site] on the window and download Version 8.2.
    3. If Availability says “N”, you need to renew your license support to update.
      Please purchase a Renewal License and renew your license support.
  • What happens when my support expires?

    If you are using an Individual License

    You will be able to continue to use Astah.
    However you will not be able to upgrade to newer versions or receive all the benefits the support offers.

     

    If you are using an Organizational Perpetual License

    All the users can continue to use Astah but unsupported.
    You won’t be able to update to the newer version and lose all the benefits plus your access to license portal.
    Therefore, when support is not renewed, a number of Individual Perpetual Licenses will be issued and delivered to the license administrator for distribution. These licenses will allow for continued use of Astah, but will be un-supported.

section divider

Setup

  • How can I install Astah in silent mode?

    Yes, use the command below.


    e.g: Installing Astah Professional 8.2

    astah-professional-8_2_0-66631d-jre-64bit-setup.exe /verysilent

    If you would like to install Astah to a specific directory, use /DIR option.

    astah-professional-8_2_0-66631d-jre-64bit-setup.exe /verysilent /DIR=”the destination of installataion folder

     

    NOTE

    • License file (.xml) should be directly saved in the Astah Installation folder.
    • If you have a Faculty Site License, a license file(.xml) should be renamed from “astah_faculty_license.xml” to “astah_porifessional_license.xml” when directly saving in the Astah Installation folder.
  • Where can I see the system requirements?
  • How can I change a Machine to use Astah?
    1. Make a back up files of the following on your curremt machine if you have:
      • Plugins: Userhome/.astah/sysml/plugins
      • User templates:Userhome/.astah/sysml/template
      • Customized system properties: Userhome/.astah/sysml/JudeY.properties
      • Customized UseCase Description template: Userhome/.astah/sysml/UCDescriptionProp.properties
    2. Uninstall Astah completely from the current machine
    3. Download and install Astah on new machine
    4. Restore the back up data to the new machine.
    5. Have your license file reissued and set from [Tool] – [License] – [Set License Key].
  • How can I increase the performance of Astah?

    The performance level of Astah depends on the RAM capacity of your machine. Try the following methods:

    Use the latest Java environment

    Refer to the How to use a specific version of the JavaVM and use the latest version of Java.

    Turn off the mouse cursor tracing option

    In some environments, having this option on will make rendering slower.

    Tune some garbage collection settings

    When the value of INITIAL_HEAP_SIZE is set to 16m, the garbage collection does not work fully unless your computer uses more memory than 16MB.

    Use the latest version of Astah

    Download the latest version is available from Download page.

    Close Map View

    Closing the Map View could increase the performance a little. To close, go to [Tools] – [System Properties] – [Project View] and take the tick off the [Show Map View below Project View].

    Disable Content Assist and Suggest Feature

    Disabling the Content Assist (A dotted green line that appears on the diagram when you try to move and align objects with others) and Suggest Feature could increase the performance a little. To close, go to [Tools] – [System Properties] – [Diagram Editor] and take the tick off two options.
    Draw suggest

section divider

Functionalities

  • Does Astah Support Object Diagrams?

    Yes. Please create Object diagrams using the Class diagram.
    Please use [Instance Specifications] and [Link] are on the Tool Bar of Class Diagrams.

  • How can I hide mini icons that appear when I have a mouse over a Class?

    There are three ways to hide the mini icons.
    draw-s

     

    1. Hold [Shift key] down
    Suggest icons never appear while [Shift] key is pressed down.

    2. Hide from the current diagram
    Click [Suggest Feature] icon on the diagram tool bar to turn it off.

     

    3. Hide from all by default
    Go to [Tools] – [System Properties] – [Diagram Editor] and turn off the [Enable Suggest Feature].

section divider

Troubleshooting

  • My Astah file does not open.

    Astah project files (.asta) are upward compatible. If project files have been edited by newer version, they cannot be opened in older version of Astah. For information about model versions, click here.

    If you cannot open project files using appropriate version of Astah, please change the stack size in the [Tools] – [System Properties] – [File].

  • I copied objects but when I edit one, the change applies to the another.

    In that case, Clone the model instead of copying. A cloned model will be an independent model.

  • How can I use a specific version of Java?

    If you have a preferred Java to use Astah, you can use it by following the instruction below. However technical support is not provided if you are using Astah on un-supported System Requirements.

    When you use un-supported Java to run Astah, you will get the alert when launching Astah. To ignore this alert,, add-nojvchk option at launch.

    Windows

    1. Have your preferred JDK installed on your PC
    2. Rename the “jre” folder in the Astah install folder to something else
    3. Astah detects the latest Java (Should be the Java you installed at step 1) in your PC and then automatically uses it to run.

    Mac

    1. Copy a “jre” folder in the JDK installation folder you prefer to use
    2. Right-click Astah App and select [Show Package Contents] from its pop-up menu
    3. Paste the “jre” folder under Contents/Plugins/JDK/Contents/Home.

    Linux

    Please refer to “How to run Astah on Linux“.

  • Where are the Astah log files?

    When you are asked to send log files along with your bug report, please send the 2 log files that are stored in your home directory:

    • astah_pro.log
    • astah.log

    You can find them in the USER_HOME\.astah\professional directory.

    Additionally, if your bug may be related to the plug-ins, please send us the log file accordingly which you can also find in the USER_HOME\.astah\professional directory.

    • C++ Reverse Plugin: cplusreverse.log
    • C# Reverse Plugin: csharpreverse.log
    • Easy Code Reverse Plugin: easycodereverse.log
    • State Transition Table: statematrix.log
    • State Transition Path: statepath.log
    • DB Reverse Plug-in: dbreverse.log