Creating a new project file

You can create a new project file by:

  • Going to [File] – [New] or
  • Clicking the most-left icon on a Tool bar
    create new project
section divider

Open a pre-installed template file

The useful template files are pre-installed in Astah Installation folder\template\project.

Astah template files

To open one of these template files, go to [File] – [New from Template] and select a file.

section divider

Create a custom template

You can create a custom template file and make it a default file to open from [File] – [New].

  1. Create a custom template file
  2. Save this .asta file in User_Home\.astah\professional (or uml)\template\project
    ※You have to create the “template” and “project” folders by yourself
  3. Go to [Tools] – [System Propertiles] – [Project] and select [User Template], then all the .asta files will appear in the drop-down list. Choose the one you’d like to use and click [Apply] – [OK].


  4. Now every time you create a new file, your custom template file opens to start with.
section divider

Create a diagram

You can create a new diagram from [Diagram] menu.
Astah Diagram Menu

section divider

Auto-save .asta files

You can autosave files by turning the auto-save mode on.
auto-save

You can specify how frequently you want to auto-save from [Tools] – [System Properties] – [File].
auto-save-menu